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Quick Start User Manual

Our powerful yet easy-to-use 
software simplifies and expedites your 

design and delivery of customized cabinets, 

doors, and closets. From concept through 

production, KCD gives you the software you 

need to save time, reduce errors, increase 

productivity, and help customers under-

stand your design. 

NOTE: For additional on-line help,  
go to KCDsoftware.com and visit our  

video tutorials and How-To’s.

KCD Software, a Division of Unified Global Technologies
1252 Route 28, South Yarmouth, MA 02664 
Contact us: 
By phone: 508-760-1140 (USA) 
By email: info@KCDsoftware.com 
For training videos: KCDsoftware.com

Copyright © 2017 by KCD Software. All Rights Reserved.
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1. Menu Bar – Selections from the menu bar give you 
access to more detailed commands.

2. Tool Bar – Quick access to common commands and 
tools.

3. Workspace – Area in which projects are built. Several 
different views are available for this area, including floor 
plan, elevation, and 3-D. 

4. Library – Drop down menu to select current library 
set, including frame, frameless, overlay frame, closet, 
Cabinotch®, and accessories.

5. Units Menu – Contains all the elements of your  
selected design library.

6. Open Space Locator Bar – Amount of open space 
(in blue) to the left or right side of an existing unit at the 
Top and Bottom of a wall. It also indicates where the 
space begins. 

7. Information Box – Size and/or angle of units and 
walls. This value changes as you drag a unit or wall to 
size or place. Also displays useful information for using 
KCD Software, such as “Add Wall First.”

Welcome to the KCD community and thank you for purchasing 

or renting KCD Software. The step-by-step procedures in this 

user manual will get you started; if you need more details,  

please visit our online How-To’s and video tutorials or call us at 

1-508-760-1140. We’re always pleased to hear from our customers. 

Let’s begin by describing the main KCD Software sceen.

Understanding the Main Screen1CHAPTER
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NOTE: Each library  
uses a default color group  

and texture group.  
However, you can change  
colors as briefly described  

in Chapter 6  
and textures as briefly  

described in Chapter 10.  
For more details, go to  

KCDSoftware.com  
and visit our online video  
tutorials and How-To’s.

Frame and overlay frame cabinets differ on how the doors 
overlay the cabinets. In frame the doors are sized from  
the opening (door lip). The door is larger or smaller than 
the opening by a fixed value. For example, a 12 by 20 
opening might have a 12½ by 20½ door (with ¼” lip).

In overlay frame or frameless, the doors are sized from 
the outside edges of the cabinet. The doors have reveals, 
which are the amount of cabinet frame or box that is  
exposed when the door is closed. For example, a 21  
by 30 cabinet might have a 20½ by 29½ door (with ¼” 
reveals).

TO SELECT A LIBRARY:

1. Click on Library in the menu bar.

2.  Select the library you want. A checkmark appears  
beside your selection and the menu closes. 

THE LIBRARIES INCLUDE:

• Frame – Elements for designing face frame cabinetry.

• Frameless – Elements for designing European,  
or frameless, cabinetry.

• Overlay Frame – Elements for designing overlay  
frame cabinetry.

• Closet – Elements for designing closet cabinetry.

• Cabinotch® – Elements for designing cabinetry using 
direct-to-Cabinotch Innovative Solutions production. 
Available in KCD’s Cabinet Professional, Cabinet/Closet 
Professional, and higher software levels only. 

• Accessories – Items to enhance the look of your 
design, such as housewares, office equipment, lighting, 
furniture, and architectural features. You cannot change 
shop standards for accessories.

KCD Software comes with several libraries, including frame and 

frameless cabinets and closets. Each library is pre-set with shop 

standards. For example, for the frame library, the standards include 

default measurements for height and depth of cabinets, distance 

from the floor to the top of the top cabinets, and kick space.

Selecting a Library2CHAPTER
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Set Shop Standards and Wall Defaults3CHAPTER

1. In the Menu Bar, choose Change > Set Shop  
Standards. 

2. Select the value you would like to change and enter 
the new value. You can scroll through the menu using 
either the up and down arrow keys or the scroll bar.

3. Click Use for This Job ONLY or click Save as  
Permanent Standards if you want every new job  
to use the same standards.

4. In the Menu Bar, choose Change >  
Set Wall Defaults.

5. Enter new values.

6. Click Use for This Job ONLY or click Save  
as Permanent Standards if you want every  
new job to use the same standards. 

You should set standards and defaults before you begin 

your project. You may want to scroll through the entire 

list of standards to see the many choices available.
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Saving and Deleting Your Work4CHAPTER

SAVING YOUR WORK
1. In the Menu Bar, click File.

2. Either: 
• If this is your first time saving,  

click Save Job As. 

• If you have saved this project before,  
click Save Job. 

NOTE: Be sure to note the location  
where you saved the project. 

DELETING PARTS OF YOUR DESIGN
To delete parts of a design from the workspace 
(walls, windows, cabinets, and so on), drag the 
object to the trash bin in the lower left corner  
of the window and release. 

You can retrieve an object from the trash  
bin during the same session by selecting  
Edit > UnDo.

DELETING AN ENTIRE JOB
1. Select File > Move or Delete Jobs >  

Delete Job from Disk. 

2. Select the file you want to delete.

3. Click OK.

4. Click Yes.



8

Once you have set your shop standards, you are 

ready to begin defining the room by adding walls 

to your project workspace. 

ADDING A WALL

1. Click Add Wall. A grid appears. 
(This is your workspace.) 

2. Place your cursor anywhere on 
the grid and hold down the 
mouse button to drag a wall 
into place. Look in the top right 
hand Information Box for sizing 
information as you move the 
mouse.

3. Release your mouse. The Add-
Change Wall menu appears. 
You may change any number 
in the menu to customize your 
wall settings.

4. When your numbers are right, 
click OK.

NOTE: The back of the wall is the 
side with the dimension line on it. 
You cannot place cabinets on the 
back of a wall. You can place  
cabinets in back of an island or 
peninsula (see Chapter 8, page 12).

NOTE: To toggle between the floor 
plan and elevation view, press the 
Space Bar twice or double click 
anywhere in the unused workspace. 
When re-positioning or angling 
walls you must be in the floor plan 
view. 

ADDING A SECOND WALL

1. Click Add Wall.

2. Place your cursor approximately 
where you want the wall and  
drag to the length you want. The 
Add-Change Wall menu appears.

3. Click OK.

4. The second wall will snap into 
position, attached to the first wall.

Adding and Positioning Walls and Islands5CHAPTER

NOTE: When creating  
a drawing, it’s best to 
leave one side open.  

If you create a closed box,  
the extra wall will block 

you from seeing the  
room in 3D.

Continued on page 9



9

SWITCHING BETWEEN WALLS

When a wall (or island/peninsula)  
is placed on the project workspace,  
it is assigned a number. Numbers  
are assigned in the order that walls 
are created.

To select a wall, either:
• Click on the wall so that it turns 

gray.

• Type a wall number to activate a 
particular wall.

CHANGING THE ANGLE  

OF A WALL

1. In the floor plan view, place the 
cursor on one end of the wall. 

2. Hold down the mouse button  
(the mouse pointer will turn into 
cross arrows).

3. Drag the end of the wall to change 
its angle on the grid and release 
the mouse button.

While dragging, look in the upper 
right hand Information Box of the 
screen for the wall angle information 
(see circled area in the screenshot 
below).

ADDING AN ISLAND  

OR PENINSULA

Islands and peninsulas operate  
the same as walls (including  
positioning and angling), with a few 
exceptions. They are represented  
on the floor plan by a dotted line. The 
most notable difference from  
a wall is that cabinetry can be placed  
on both the front and back of an 
island or peninsula. 

1. Click Add Island. 

2.  Place your mouse pointer  
anywhere on the grid and hold 
down the mouse button to drag 
the island or peninsula into place. 
(If your line is close to a wall, it will 
snap into place as a peninsula,  
not an island.)

3.  Release your mouse. The Add-
Change Wall menu appears.  
You can change any number in  
the menu to customize your island 
or peninsula settings.

4. Click OK. For activating the back 
wall of an island/peninsula, see 
Chapter 8.

Adding and Positioning Walls and Islands  CONTINUED5CHAPTER
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1.    Place the mouse pointer on any 
wall or island/peninsula and 
double click. The Add-Change 
Wall menu appears.

2.    Click the More button to see  
the full menu shown here.

3.     To change a value, click the  
value to be changed and type  
in the new value.

4.   Click on OK to apply the 
change(s).

Wall Length — Length of wall, 
island, or peninsula. 

X Location — The higher the X  
value the farther from the left  
side of the grid. 

Y Location — The higher the Y  
value the farther from the top  
of the grid. 

Angle — The wall’s angle. 

Wall Height — Height of the wall 
from floor to ceiling. 

Island/Peninsula — Change from  
a wall to an island/peninsula or 
back again: click on the box to 
add a checkmark (create island/
peninsula) or remove a checkmark 
(create a wall). 

Less/More — This button hides/
reveals additional fields located 
below the Room Name and  
Number fields.

Wall Name & Number —  
Label for the current wall. You can 
cycle though the walls within the 
room by using the up and down 
arrows next to the number box.  

Room Name & Number — Label for 
the current room. If you change 
the room number, the wall and 
any units attached to it will be 
added to the room indicated. 

Flip Wall 180 Degrees — Flips  
the wall with all its units, while 
maintaining its position within  
the workspace. You may need  
to flip a wall after moving it from 
one side of the workspace to  
the opposite side.  

Change Length on — Which end  
of the wall will extend or retract 
with a change in length.

Thickness – Thickness of wall.

Top/Base # Depth – The distance 
that a cabinet can be located 
from the wall and still show on the 
elevation view. Cabinets located 
outside this limit do not appear  
in the elevation view.

Change Wall Color – Click Change 
Wall Color; select the color you 
prefer; then click Set the Color. 
The wall color may show clearest  
in elevation and 3D views.

Edit Wall Shape – When you  
click Edit Wall Shape, the view 
automatically changes to elevation. 
Select the shape you prefer, then 
click Apply.

Once a wall is added, you can modify it at any time  

by changing settings such as height, length, thickness,  

and color at the Add-Change Wall menu. 

Changing Wall or Island/Peninsula Settings6CHAPTER
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Adding a Window or Room Door7CHAPTER

Windows and doors can be added on the floor plan but 

it may be easier to see what you are doing in elevation 

view. To switch views, either press the Space Bar twice  

or double click anywhere in the unused workspace.

1. Select the wall where you 
want to enter a window 
or door to make the wall 
active (it appears shaded).

2. In the Units Menu, double 
click on Window or Door.  

3. Click anywhere on the 
active wall to bring up 
the outline of a window 
or door. A menu appears 
where you can change all 
the specifications, includ-
ing width, height, location, 
and style (for example, 
double hung or sliding). 

4. To change the location, first 
select one of the choices 
under Locate From. For 
example, to locate a win-
dow a certain distance from 
the left wall, select L to L 
(measures the distance from 
the left wall to the left edge 
of the window) or L to C 
(measures the distance from 
the left wall to the center of 
the window).

5. Enter the distance in the 
Location box or select C 
(next to the Location box) to 
center the window or door 
on the wall.

6. Click OK.
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Once you have placed and sized your wall(s) and located 

windows and doors, you are ready to add cabinets.  

The library you selected earlier (frame, frameless,  

overlay, closet, Cabinotch®) determines which units are 

available. Units are placed on the active (shaded) wall. 

ADDING A CABINET TO A WALL OR 

ISLAND / PENINSULA

NOTE: Unit numbers are assigned by the  
software in the order in which the units are 
added to the design. In the screenshot at  
the far right, unit #2 is circled. 

1. Select the wall (or the dotted line of the 
island/peninsula) where you want to add a 
cabinet to make the wall active.

2. Click on the category of cabinet on the 
Units Menu (for example, Base Cabinets)  
or click the ± button to expand the list.

3. Click on the type of cabinet you want (for 
example, Base 4 Drawer).

4. Drag the outline of the cabinet to the  
desired size on the wall you selected. 

5. Release the mouse. The Add Unit menu  
appears. From here you can customize sizes 
and other specifications, including color.

6. When your changes are complete, click OK.

ACTIVATING THE BACK WALL OF AN 

ISLAND/PENINSULA

Cabinets can be placed on both sides of  
an island/peninsula. It is easiest to work in 
elevation view. To toggle from front to back  
of the island/peninsula:
• Click the right mouse button to activate  

the back of the island. 

• Click the left mouse button to activate  
the front of the island.

Locating and Sizing Cabinets on Walls 8CHAPTER

NOTE: The steps  
below for adding  

a cabinet will work for  
other types of units,  
such as refrigerators  

and stoves.

REPOSITIONING A CABINET

You can reposition cabinets and other units  
(like refrigerators) from either the floor plan  
or elevation views. 
1. Place the cursor on the cabinet number.

2. Drag the cabinet to the new location and 
drop it into place by releasing the mouse 
button. 
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Cabinets and other units are easily customized.  

Once you have placed cabinets on a wall, you may 

customize their doors, change their color or texture, 

and add handles, pulls, and hinges. Working in  

elevation view makes it easier to see your changes.

Customizing Cabinets9CHAPTER

NOTE: To create a  
door pair (two facing 
doors opening to one 

space), choose  
Doors > Change 1 Door 

and select Door Pair.  
In door pairs,  

changes applied to  
one of the pair are  

automatically applied  
to the other door  

in the pair.  

CUSTOMIZING EXISTING CABINET

1. Double click on the cabinet’s number 
to open the menu.  

2. Select the value(s) to be changed  
and type in the new value(s), including 
the color.  

3. Click OK and the changes will be 
applied.

The screenshot below is an example. 
The values change depending on the 
type of unit.  

NOTE: Parameters preceded by “!!”  
can be toggled between 0 and the 
shop standard by double clicking  
on the “!!”.

Continued on page 14
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Customizing Cabinets  CONTINUED9CHAPTER

CHANGE ALL CABINET DOORS

Cabinets are shown with default 
doors but you can customize them  
at any time. 
1. From the Menu Bar, choose Doors 

> Change Doors on this job.

2. The door style menu appears.

3. Choose a category of door  
(including square panel, flat,  
arch panel, and glass) from the  
two drop down menus on the  
top right.

4. Drag the door you want from  
the right side of the menu to  
the Doors on This Job section  
on the left. 

5. Drop the selected door style on the 
Top Door, Drawer Front, or Base 
Door picture by releasing  
the mouse.

6. Click Set in This Room or click  
All Rooms if you want the selected 
door style(s) to apply to all rooms 
in the project.

CHANGE DOORS ON  

ONE CABINET

You have two choices for changing 
the doors on one cabinet: using the 
Main Menu or using the short-cut.

Using the Main Menu:
1. Choose Doors > Change 1 Door 

and a menu appears.

2. Enter the Unit # of the cabinet  
to be changed.

3. Enter the Opening #. Openings 
(drawers, doors) are numbered 
from top left to bottom right  
of each cabinet.

4. Select a door type from the  
Loaded Doors list.

5. Click Make Change.

6. Click Close.

Continued on page 15
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Using the shortcut:
1. Place the cursor on the cabinet 

door to be changed.

2. Hold down the Ctrl key and click 
the mouse.  Each click will cycle 
you though door styles you placed 
in the Doors on This Job and Extra 
Doors sections, plus one additional 
selection of No Door.

3. Release the Ctrl key to apply the 
door you want.

ADDING HANDLES TO  

CABINET DOORS

1. From the Menu Bar, choose Doors 
> Add Handles & Hinges to open 
the handles menu.

2. Drag the handle you want from  
the right to the Top, Drawer, or 
Base handle on the left.

3. Select placement, location,  
and orientation as appropriate.

4. Click Set in This Room or click  
All Rooms. 

Customizing Cabinets  CONTINUED9CHAPTER NOTE: Extra Doors are 
used when changing one 
door and Extra Handles 
are used when changing 
one handle. Drag your 
selection from the right 

to the left, and drop it on 
one of the available extra 

door or handle spaces.

Continued on page 16
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CHANGING CABINET DOOR 

HANDLES

You can change the style and position 
of a single handle from within the  
elevation view (not the floor plan 
view). 

To change the handle style:
1. Place the cursor on the handle  

to be changed.  

2. Hold down the Shift key and  
right-click the mouse. 

3. Each click cycles through vertical, 
horizontal, and knob handles, as 
well as no handle.

4. Release the Shift key. 

To change the handle position:
1. Place the cursor on the handle  

to be changed.  

2. Hold down the Shift key.

3. Click on the new position where 
you want the handle.

4. Release the Shift key. The  
handles and hinges both move  
to the new position.

NOTE: There are 9 positions for door 
handles: top, middle, and bottom 
on the vertical; and left, center, and 
right on the horizontal. There are 6 
positions for drawers: top, middle, 
and bottom on the center; and 
dual knobs or handles.  
For example:

CHANGING HINGES

Hinges are defined by dotted lines, 
which show how a cabinet door will 
open. The door opens from the wide 
end of the dotted lines.

1. To change the hinge placement, 
place the mouse pointer on the 
dotted line for the hinge.  

2. Hold down the Ctrl key and right-
click on the side of the door where 
you want the hinge.

NOTE: The handles do not change 
position.

Customizing Cabinets  CONTINUED9CHAPTER
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Changing Views in 2D10CHAPTER

KCD Software lets you work quickly in 2D, moving back 

and forth easily between floor plan and elevation views. 

Viewing your designs in 3D makes it easy to refine your 

details and present realistic drawings to clients.

CHANGING BETWEEN 2D VIEWS

To switch from floor plan to elevation view:
1. Select the wall you would like to see in elevation  

view by clicking on it (it turns gray)

2. Double click anywhere in the unused portion of  
the workspace or press the Space Bar twice.

To switch from elevation to floor plan view:
1. Double click anywhere in the unused portion of  

the workspace or press the Space Bar twice.

 Both floor plan and elevation views are considered  
2D (two-dimensional).

Wall selected  
for elevation view
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Moving around in 3D11CHAPTER

To view your design in three-dimensions, select 3D on the main menu and wait 

a moment while your design renders. Then, using your mouse, touchscreen, 

touchpad, or the buttons shown in the 3D window on page 19, you can MOVE 

Camera (change your view of the room), MOVE Picture (change the placement 

of the image in the workspace), or Zoom (increase/decrease the picture). 

Select 2D when you are ready to return to your elevation or floor plan view.

TIPS FOR CREATING  

A REALISTIC 3D VIEW

Please keep these tips in mind to 
create the most realistic 3D view:

• Start your perspective at eye level: 
Move Camera up or down until it is 
at normal eye level (rather than far 
below or above).

• Center: Move Picture left or right  
to center it in the workspace.

• Fill the workspace: Zoom Picture 
Size until the room fills the work-
space. Generally, rooms look best 
between 100 and 300.

• Unblock view: Options lets you tem-
porarily Hide From Drawing any 
walls or units that are blocking the 
view you want to feature.  
Click on the items you want to 
hide, then click Hide and Redraw.

• Fix lighting: Options lets you 
change the Room Brightness. 
Select brightness you want,  
then click Hide and Redraw.

MOTION MOUSE TOUCH PAD TOUCH 
SCREEN

MENU  
BUTTONS

MOVE  
Camera

Left button 
drag

•  Place your 
cursor over 
the image. 

•  May act like  
a Mouse  
or like a 
TouchScreen. 

•  Menu buttons 
are always 
available as 
backup.

Touch + drag
“Move Camera” 
(6 buttons)

MOVE  
Picture

Right button  
drag

•  Hold Touch  
(2 sec.) + drag

•  Or Two finger 
drag

“Move Picture”
(4 buttons)

Zoom Mouse Wheel
Two finger 
pinch

“Zoom Picture”
2 buttons
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CHAPTER              Changing Textures and Materials12

1. From within the 3D menu, click on 
the Options button.

2. From the Options menu, click on 
Set Textures. 

3. From the Textures box, click on the 
item to be customized (in this case, 
we clicked on Group 1 Cabinet).

4. Click on the material (in this  
case, Wood). 

5. Click on the texture type (in this 
case, Hickory).

6. If you want to change the color or 
shade (for example, to darken the 
hickory): 
•  Click Blend Color with Texture. 
• Make your selection. 
• Click Set this Color.  
• Click Close.

7. Click Set This Texture, then  
Close to apply the changes.

When you change textures or materials, you might 

change the type of wood or color used in a cabinet 

or the material (Formica, stone, granite) used on  

a countertop, or the color of a wall.

NOTE: You may not  
see Blend Color with  
Texture. If you see  
Replace Color with  

Texture, then the texture 
is applied “as is”;  

color cannot be added.
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To print a 3D view of a project, you must first have 

the 3D view on the screen (not an elevation or floor 

plan view) when you go to Print. From the main 

menu select 3D. Your job will display in 3D. You can 

move your image around to your preferred 3D view.

PRINTING VIEWS

To print your desired views:

1. Click 3D on the Main Menu if you 
haven’t yet.

2. Choose File > Print Drawings to 
open the Print menu.  

3. Choose 1 or More Views by click-
ing on and highlighting the item(s) 
to be printed (deselect views the 
same way). (Elevation #1 equals 
wall or island #1 and so on). All 
highlighted views are printed when 
you click Print. 

Choose 1 or More Views – The 
item(s) to be printed. Select view(s) 
to highlight or remove highlight. 
All highlighted views are printed.

Options – Items to be included in 
print. A checkmark includes that 
item on the print, for example a 
check next to Show Doors adds 
doors to the print. 

Dimensions – The measurements 
(length, width, depth, overlay) of 
cabinets, walls, windows, doors, 
etc., from None (no measurements 
shown) to Level #4 (all inside and 
outside measurements shown). 
Dimensions will print even if they 
are not shown on screen.

Printer Scale – The scale of the 
print. Auto scale fits the whole 
page. If the selected scale  
does not fit on the page, only a 
portion of the design will print.

Orientation – The orientation of the 
print on the page, Landscape or 
Portrait.

Color or Black & White – Prints the 
view in color or black and white.

Printing Views and Multi-Prints13CHAPTER

Continued on page 21
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Printing Views and Multi-Prints  CONTINUED13CHAPTER

PRINTING A PAGE OF  

IMAGES (MULTI-PRINT)

In 3D view, you can also print  
multiple images to a single page  
as either .jpg or .pdf files.

1. Go to the image (floor plan,  
elevation, 3D) that you want to 
print.

2. Choose File > Add this Drawing  
to Multi-Print.

3. If you want to add a picture from 
within KCD Software (including  
2D pictures) or from another  
computer location: 

• Choose File > Import Picture  
into Multi-Print.

• Select the picture you want  
to add (it must be .bmp, .jpg,  
or similar format, not .pdf).

• Click OK.

4. Choose File > Print Multi-Print 
Drawing.  

5. A draft of the multi-print  
drawing appears onscreen.

6. On the right side of the screen  
are images and notes you  
can drag onto the page that  
you will print.

7. On the left side of the screen are 
images and notes you can drag  
off the page that you will print.

8. When you are satisfied, click  
Print to print. 

NOTE: Your design  
may contain walls with no 

units on them.  
The + symbol after a view 

in the Print menu  
denotes a wall with units. 

Select All Active Views  
will highlight only  
views with units.  

To include an inactive 
view, click on the inactive 

view you want to add  
to the list.

TO RE-SIZE AN IMAGE:

ENLARGE – Hold down the Shift key  

and Left-click on the image multiple 

times or use the scroll wheel.

REDUCE – Hold down the Shift key  

and Right-click on the image multiple 

times or use the scroll wheel.

Drag and drop images 

back and forth to lay 

out your Multi-Print.
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Notes
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CONTACT US: 
By phone:  508-760-1140 (USA) 

By email:  info@KCDsoftware.com 
For training videos:  KCDsoftware.com


